Results 1 to 2 of 2

Thread: Lower unit slipping under load?

  1. #1
    Join Date
    Jul 2015
    Posts
    6

    Default Lower unit slipping under load?

    93 Yamaha lower unit installed last season ran fine 2014 and up until this month from April 2015....then seemed to start slipping...finally lost thrust completely in fwd and reverse? Seems to shift F N R but can turn prop manually in both directions in gear? When out of the water in gear prop seems to turn F and R but in water, no thrust? We thought at first it might be spun prop, but when we checked and found we could turn in gear both directions without locking, we knew it was something in the unit...maybe clutch dogs? There is no grinding noise shifting in F N R ? Water pump seems to be pumping ok and engine runs ok...but just before the gears slipped, it started overheating all alert warnings came on...oil to engine was fine, water pump seemed to be pumping??? What do you think the problem may be?

    Thanks

  2. #2
    Join Date
    Nov 2006
    Posts
    661

    Default

    Please look at your thread over in general discussion.

    Tech Support

  3. #3
    Join Date
    Jul 2015
    Posts
    6

    Default Lower unit shipping under warranty?

    Quote Originally Posted by admin View Post
    Please look at your thread over in general discussion.

    Tech Support
    My mechanic checked out my unit, which was only 1 season old and determined that it had an issue with failure of the clutch dogs and sent it back to you for repair. My question is, is shipping covered in the warranty? Because of the size and weight, it could be substantial. The unit has been at your plant now for over three weeks and we last checked, we were told that you had a shortage of cases for repairs? I thought that you would use the old case as it was in seemingly good shape still?

    I would appreciate answers to those two concerns...who pays for shipping a returned unit under warranty and why not use old cases if still serviceable?

    Thanks,
    Leo Mehalic
    Annapolis, MD

  4. #4
    Join Date
    Jul 2015
    Posts
    6

    Default

    Quote Originally Posted by sailingunc View Post
    93 Yamaha lower unit installed last season ran fine 2014 and up until this month from April 2015....then seemed to start slipping...finally lost thrust completely in fwd and reverse? Seems to shift F N R but can turn prop manually in both directions in gear? When out of the water in gear prop seems to turn F and R but in water, no thrust? We thought at first it might be spun prop, but when we checked and found we could turn in gear both directions without locking, we knew it was something in the unit...maybe clutch dogs? There is no grinding noise shifting in F N R ? Water pump seems to be pumping ok and engine runs ok...but just before the gears slipped, it started overheating all alert warnings came on...oil to engine was fine, water pump seemed to be pumping??? What do you think the problem may be?

    Thanks
    Thanks for info...we varified that the unit had bad clutch paws and warranty office authorized sending it back...it has been over three weeks and when we checked, were told you were backed up for cases to use to repair the unit under warranty. I have missed three weeks or more of prime boating season, plus had to pay over $200 for shipping? Why? Once it is fixed, is it warranteed for another three years...and who pays to ship it back to me?

  5. #5
    Join Date
    Jul 2015
    Posts
    6

    Default Not happy with warrasnty service!

    Quote Originally Posted by sailingunc View Post
    93 Yamaha lower unit installed last season ran fine 2014 and up until this month from April 2015....then seemed to start slipping...finally lost thrust completely in fwd and reverse? Seems to shift F N R but can turn prop manually in both directions in gear? When out of the water in gear prop seems to turn F and R but in water, no thrust? We thought at first it might be spun prop, but when we checked and found we could turn in gear both directions without locking, we knew it was something in the unit...maybe clutch dogs? There is no grinding noise shifting in F N R ? Water pump seems to be pumping ok and engine runs ok...but just before the gears slipped, it started overheating all alert warnings came on...oil to engine was fine, water pump seemed to be pumping??? What do you think the problem may be?

    Thanks
    Thanks for info...we varified that the unit had bad clutch paws and warranty office authorized sending it back...it has been over three weeks and when we checked, were told you were backed up for cases to use to repair the unit under warranty. I have missed three weeks or more of prime boating season, plus had to pay over $200 for shipping? Why? Once it is fixed, is it warranteed for another three years...and who pays to ship it back to me?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

115 S. Forest Lakes Blvd.
Oldsmar, FL 34677

tel: 813.925.7127
fax: 813.925.7064


Sterndrive Engineering, Inc. (SEI) manufactures a stern drive designed to replace Mercury Marine's MerCruiserŽ Alpha OneŽ, R, MR, Gen II and Bravo OneŽ stern drives. MerCruiserŽ Alpha One, R, MR, Gen II and Bravo OneŽ are trademarks of the Brunswick Corporation. SEI has no affiliation with the Brunswick Corporation. Consequently, any warranties governing products and or sold by Brunswick Corporation will not apply to products manufactured and or sold by SEI, or to products damaged due to the operation of an SEI product.